import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *([\\+\\-]?) *(?>([0-9]+)[.,]?([0-9]*)|[.,]?([0-9]+)) *%? *$";
final String string = " - 123.987 %";
final String subst = "$1$2.$3$4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}