use strict;
my $str = 'IP Table:
CIP_ID Type Status DevID Port IP Address/SiteName
AD GWAY OFFLINE 4 41794 192.168.088.053
DM-MD8x8>';
my $regex = qr/\b[A-F0-9][A-F0-9]?\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}