const regex = new RegExp('\\b[A-F0-9][A-F0-9]?\\b', 'g')
const str = `IP Table:
CIP_ID Type Status DevID Port IP Address/SiteName
AD GWAY OFFLINE 4 41794 192.168.088.053
DM-MD8x8>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}