using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-F0-9][A-F0-9]?\b";
string input = @"IP Table:
CIP_ID Type Status DevID Port IP Address/SiteName
AD GWAY OFFLINE 4 41794 192.168.088.053
DM-MD8x8>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}