import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-F0-9][A-F0-9]?\\b";
final String string = "IP Table:\n"
+ "CIP_ID Type Status DevID Port IP Address/SiteName\n"
+ " AD GWAY OFFLINE 4 41794 192.168.088.053\n\n"
+ "DM-MD8x8>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}