import Foundation
let pattern = #"cat(?![^<]*>|[^<>]*<\/mux-video>|[^"'<>]*href\s*=\s*['"][^'"]*['"])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
text with a cat
<img src="path/to/cat.jpg" />
<mux-video source="path/to/cat">cat</mux-video>
more text with capital Cat CAT cAT
<a href="path/to/cat.pdf">this should match cat</a>
works!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)