using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cat(?![^<]*>|[^<>]*<\/mux-video>|[^""'<>]*href\s*=\s*['""][^'""]*['""])";
string input = @"text with a cat
<img src=""path/to/cat.jpg"" />
<mux-video source=""path/to/cat"">cat</mux-video>
more text with capital Cat CAT cAT
<a href=""path/to/cat.pdf"">this should match cat</a>
works!
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}