use strict;
my $str = 'text with a cat
<img src="path/to/cat.jpg" />
<mux-video source="path/to/cat">cat</mux-video>
more text with capital Cat CAT cAT
<a href="path/to/cat.pdf">this should match cat</a>
works!
';
my $regex = qr/cat(?![^<]*>|[^<>]*<\/mux-video>|[^"'<>]*href\s*=\s*['"][^'"]*['"])/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}