re = /cat(?![^<]*>|[^<>]*<\/mux-video>|[^"'<>]*href\s*=\s*['"][^'"]*['"])/i
str = 'text with a cat
<img src="path/to/cat.jpg" />
<mux-video source="path/to/cat">cat</mux-video>
more text with capital Cat CAT cAT
<a href="path/to/cat.pdf">this should match cat</a>
works!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end