#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)cat(?![^<]*>|[^<>]*<\/mux-video>|[^"'<>]*href\s*=\s*['"][^'"]*['"])"
Local $sString = "text with a cat" & @CRLF & _
"<img src="path/to/cat.jpg" />" & @CRLF & _
"<mux-video source="path/to/cat">cat</mux-video>" & @CRLF & _
"more text with capital Cat CAT cAT" & @CRLF & _
"<a href="path/to/cat.pdf">this should match cat</a>" & @CRLF & _
"works!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")