re = /((_%{.*})|%{.*}_)/m
str = 'stub-service_%{[service][port]}_/esb/stub/v1/service
stub-service_/esb/stub/v1/service_%{[service][port]}
%{[service][port]}_stub-service_/esb/stub/v1/service'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end