const regex = /((_%{.*})|%{.*}_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((_%{.*})|%{.*}_)', 'gm')
const str = `stub-service_%{[service][port]}_/esb/stub/v1/service
stub-service_/esb/stub/v1/service_%{[service][port]}
%{[service][port]}_stub-service_/esb/stub/v1/service`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}