package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((_%{.*})|%{.*}_)`)
var str = `stub-service_%{[service][port]}_/esb/stub/v1/service
stub-service_/esb/stub/v1/service_%{[service][port]}
%{[service][port]}_stub-service_/esb/stub/v1/service`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}