#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((_%{.*})|%{.*}_)"
Local $sString = "stub-service_%{[service][port]}_/esb/stub/v1/service" & @CRLF & _
"stub-service_/esb/stub/v1/service_%{[service][port]}" & @CRLF & _
"%{[service][port]}_stub-service_/esb/stub/v1/service"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")