using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((_%{.*})|%{.*}_)";
string input = @"stub-service_%{[service][port]}_/esb/stub/v1/service
stub-service_/esb/stub/v1/service_%{[service][port]}
%{[service][port]}_stub-service_/esb/stub/v1/service";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}