$re = '/((_%{.*})|%{.*}_)/m';
$str = 'stub-service_%{[service][port]}_/esb/stub/v1/service
stub-service_/esb/stub/v1/service_%{[service][port]}
%{[service][port]}_stub-service_/esb/stub/v1/service';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);