import Foundation
let pattern = ##">([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##">1234567890< 123451234#"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)