use strict;
my $str = '>1234567890< 123451234#';
my $regex = qr/>([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}