const regex = />([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>([0-9]{10})[-<;]\\s{1,2}([0-9]{4})([0-9]{5})#(\\s([0-9_\\?]{0,8}))?(\\+\\s([a-z0-9_\\?]{0,5}))?(\\-\\s([\\.,0-9_\\?]{0,10})>)?', 'g')
const str = `>1234567890< 123451234#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}