import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">([0-9]{10})[-<;]\\s{1,2}([0-9]{4})([0-9]{5})#(\\s([0-9_\\?]{0,8}))?(\\+\\s([a-z0-9_\\?]{0,5}))?(\\-\\s([\\.,0-9_\\?]{0,10})>)?";
final String string = ">1234567890< 123451234#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}