re = />([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?/
str = '>1234567890< 123451234#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end