package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?`)
var str = `>1234567890< 123451234#`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}