import Foundation
let pattern = #"^(?!.*note).*versa.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.stevennissan.com/new-vehicles/versa-note/
https://www.stevennissan.com/new-vehicles/versa/
https://www.stevennissan.com/inventory/new-2017-nissan-versa-note-s-plus-fwd-4d-hatchback-3n1ce2cp6hl382264
https://www.stevennissan.com/inventory/new-2018-nissan-versa-1-6-s-fwd-4d-sedan-3n1cn7ap7jl833191
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)