$re = '/^(?!.*note).*versa.*$/m';
$str = 'https://www.stevennissan.com/new-vehicles/versa-note/
https://www.stevennissan.com/new-vehicles/versa/
https://www.stevennissan.com/inventory/new-2017-nissan-versa-note-s-plus-fwd-4d-hatchback-3n1ce2cp6hl382264
https://www.stevennissan.com/inventory/new-2018-nissan-versa-1-6-s-fwd-4d-sedan-3n1cn7ap7jl833191
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);