import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*note).*versa.*$";
final String string = "https://www.stevennissan.com/new-vehicles/versa-note/\n\n"
+ "https://www.stevennissan.com/new-vehicles/versa/\n\n"
+ "https://www.stevennissan.com/inventory/new-2017-nissan-versa-note-s-plus-fwd-4d-hatchback-3n1ce2cp6hl382264\n\n"
+ "https://www.stevennissan.com/inventory/new-2018-nissan-versa-1-6-s-fwd-4d-sedan-3n1cn7ap7jl833191\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}