using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*note).*versa.*$";
string input = @"https://www.stevennissan.com/new-vehicles/versa-note/
https://www.stevennissan.com/new-vehicles/versa/
https://www.stevennissan.com/inventory/new-2017-nissan-versa-note-s-plus-fwd-4d-hatchback-3n1ce2cp6hl382264
https://www.stevennissan.com/inventory/new-2018-nissan-versa-1-6-s-fwd-4d-sedan-3n1cn7ap7jl833191
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}