# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*note).*versa.*$"
test_str = ("https://www.stevennissan.com/new-vehicles/versa-note/\n\n"
"https://www.stevennissan.com/new-vehicles/versa/\n\n"
"https://www.stevennissan.com/inventory/new-2017-nissan-versa-note-s-plus-fwd-4d-hatchback-3n1ce2cp6hl382264\n\n"
"https://www.stevennissan.com/inventory/new-2018-nissan-versa-1-6-s-fwd-4d-sedan-3n1cn7ap7jl833191\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.