use strict;
my $str = 'https://www.stevennissan.com/new-vehicles/versa-note/
https://www.stevennissan.com/new-vehicles/versa/
https://www.stevennissan.com/inventory/new-2017-nissan-versa-note-s-plus-fwd-4d-hatchback-3n1ce2cp6hl382264
https://www.stevennissan.com/inventory/new-2018-nissan-versa-1-6-s-fwd-4d-sedan-3n1cn7ap7jl833191
';
my $regex = qr/^(?!.*note).*versa.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}