// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?m)^(?:[*?_A-Za-z0-9]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?"##).unwrap();
let string = "foo\\-bar
Acrobat_Reader
\\\"oh_my\\!\\\"
g\\+\\+
9\\.?
sr*
big\\$money
foo\\:bar
back\\\\slash_software
with_quoted_\\~tilde
*SOFT*
8\\.??
*8\\.??
?hello?
\\\\help1??
hello?hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}