use strict;
my $str = 'foo\\-bar
Acrobat_Reader
\\"oh_my\\!\\"
g\\+\\+
9\\.?
sr*
big\\$money
foo\\:bar
back\\\\slash_software
with_quoted_\\~tilde
*SOFT*
8\\.??
*8\\.??
?hello?
\\\\help1??
hello?hello';
my $regex = qr/^(?:[*?_A-Za-z0-9]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}