#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[*?_A-Za-z0-9]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?"
Local $sString = "foo\-bar" & @CRLF & _
"Acrobat_Reader" & @CRLF & _
"\"oh_my\!\"" & @CRLF & _
"g\+\+" & @CRLF & _
"9\.?" & @CRLF & _
"sr*" & @CRLF & _
"big\$money" & @CRLF & _
"foo\:bar" & @CRLF & _
"back\\slash_software" & @CRLF & _
"with_quoted_\~tilde" & @CRLF & _
"*SOFT*" & @CRLF & _
"8\.??" & @CRLF & _
"*8\.??" & @CRLF & _
"?hello?" & @CRLF & _
"\\help1??" & @CRLF & _
"hello?hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")