$re = '/^(?:[*?_A-Za-z0-9]|\\\\[\\\\!"#$%&\'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\\\[\\\\!"#$%&\'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?/m';
$str = 'foo\\-bar
Acrobat_Reader
\\"oh_my\\!\\"
g\\+\\+
9\\.?
sr*
big\\$money
foo\\:bar
back\\\\slash_software
with_quoted_\\~tilde
*SOFT*
8\\.??
*8\\.??
?hello?
\\\\help1??
hello?hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);