const regex = /^(?:[*?_A-Za-z0-9]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\[\\!"#$%&'()+,.\/:;<>=@[\]^`{|}~*?-])*(?:\*|\?+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[*?_A-Za-z0-9]|\\\\[\\\\!"#$%&\'()+,.\\\/:;<>=@[\\]^`{|}~*?-])(?:[A-Za-z0-9_]|\\\\[\\\\!"#$%&\'()+,.\\\/:;<>=@[\\]^`{|}~*?-])*(?:\\*|\\?+)?', 'gm')
const str = `foo\\-bar
Acrobat_Reader
\\"oh_my\\!\\"
g\\+\\+
9\\.?
sr*
big\\\$money
foo\\:bar
back\\\\slash_software
with_quoted_\\~tilde
*SOFT*
8\\.??
*8\\.??
?hello?
\\\\help1??
hello?hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}