import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[*?_A-Za-z0-9]|\\\\[\\\\!\"#$%&'()+,.\\/:;<>=@[\\]^`\\{|\\}~*?-])(?:[A-Za-z0-9_]|\\\\[\\\\!\"#$%&'()+,.\\/:;<>=@[\\]^`\\{|\\}~*?-])*(?:\\*|\\?+)?";
final String string = "foo\\-bar\n"
+ "Acrobat_Reader\n"
+ "\\\"oh_my\\!\\\"\n"
+ "g\\+\\+\n"
+ "9\\.?\n"
+ "sr*\n"
+ "big\\$money\n"
+ "foo\\:bar\n"
+ "back\\\\slash_software\n"
+ "with_quoted_\\~tilde\n"
+ "*SOFT*\n"
+ "8\\.??\n"
+ "*8\\.??\n"
+ "?hello?\n"
+ "\\\\help1??\n"
+ "hello?hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}