// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?Um)(?J)(?<open><(?<tag>h[1-6])>)(?<text>.*)(?<close><\/?(?'tag'h[1-6])>)").unwrap();
let string = "<h1>HUe</h1>fad<b>adfkhjaldf</b>
<h2>HUe</h2>sdfasdfa
<h3>HUe</h3>sdfads
<h4>HUe</h4>fadsf<h2>a
<h5>HUe</h5>sdfasd
<h6>HUe</h6>adfadsfa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}