$re = '/(?J)(?<open><(?<tag>h[1-6])>)(?<text>.*)(?<close><\/?(?\'tag\'h[1-6])>)/Um';
$str = '<h1>HUe</h1>fad<b>adfkhjaldf</b>
<h2>HUe</h2>sdfasdfa
<h3>HUe</h3>sdfads
<h4>HUe</h4>fadsf<h2>a
<h5>HUe</h5>sdfasd
<h6>HUe</h6>adfadsfa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);