#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Um)(?J)(?<open><(?<tag>h[1-6])>)(?<text>.*)(?<close><\/?(?'tag'h[1-6])>)"
Local $sString = "<h1>HUe</h1>fad<b>adfkhjaldf</b>" & @CRLF & _
"<h2>HUe</h2>sdfasdfa" & @CRLF & _
"<h3>HUe</h3>sdfads" & @CRLF & _
"<h4>HUe</h4>fadsf<h2>a" & @CRLF & _
"<h5>HUe</h5>sdfasd" & @CRLF & _
"<h6>HUe</h6>adfadsfa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")