use strict;
my $str = '<h1>HUe</h1>fad<b>adfkhjaldf</b>
<h2>HUe</h2>sdfasdfa
<h3>HUe</h3>sdfads
<h4>HUe</h4>fadsf<h2>a
<h5>HUe</h5>sdfasd
<h6>HUe</h6>adfadsfa';
my $regex = qr/(?J)(?<open><(?<tag>h[1-6])>)(?<text>.*)(?<close><\/?(?'tag'h[1-6])>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}