# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?J)(?<open><(?<tag>h[1-6])>)(?<text>.*)(?<close><\/?(?'tag'h[1-6])>)"
test_str = ("<h1>HUe</h1>fad<b>adfkhjaldf</b>\n"
"<h2>HUe</h2>sdfasdfa\n"
"<h3>HUe</h3>sdfads\n"
"<h4>HUe</h4>fadsf<h2>a\n"
"<h5>HUe</h5>sdfasd\n"
"<h6>HUe</h6>adfadsfa")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.