package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Um)(?J)(?<open><(?<tag>h[1-6])>)(?<text>.*)(?<close><\/?(?'tag'h[1-6])>)`)
var str = `<h1>HUe</h1>fad<b>adfkhjaldf</b>
<h2>HUe</h2>sdfasdfa
<h3>HUe</h3>sdfads
<h4>HUe</h4>fadsf<h2>a
<h5>HUe</h5>sdfasd
<h6>HUe</h6>adfadsfa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}