import Foundation
let pattern = #"(?s)\.getModification\(\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
val color = Flagship.getModification("btnColor", "#0e5fe3", true)
val size = Flagship.getModification("btnSize", 13, true)
val display = Flagship.getModification("displayBtn", true, true)
val color = Flagship.getModification("btnColor", "#0e5fe3")
val size = Flagship.getModification("btnSize", -0.1)
val display = Flagship.getModification("displayBtn", true)
val color = Flagship.getModification("btnColor", "(hello world !)", true)
val size = Flagship.getModification("btnSize", "red, green blue", true)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)