re = /(?s)\.getModification\(\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\)/m
str = '
val color = Flagship.getModification("btnColor", "#0e5fe3", true)
val size = Flagship.getModification("btnSize", 13, true)
val display = Flagship.getModification("displayBtn", true, true)
val color = Flagship.getModification("btnColor", "#0e5fe3")
val size = Flagship.getModification("btnSize", -0.1)
val display = Flagship.getModification("displayBtn", true)
val color = Flagship.getModification("btnColor", "(hello world !)", true)
val size = Flagship.getModification("btnSize", "red, green blue", true)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end