#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)\.getModification\(\s*["']([\w\-]+)['"]\s*,\s*(["'][^"]*['"]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|"[^"]*"))?\s*\)"
Local $sString = "" & @CRLF & _
"val color = Flagship.getModification("btnColor", "#0e5fe3", true)" & @CRLF & _
"val size = Flagship.getModification("btnSize", 13, true)" & @CRLF & _
"val display = Flagship.getModification("displayBtn", true, true)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"val color = Flagship.getModification("btnColor", "#0e5fe3")" & @CRLF & _
"val size = Flagship.getModification("btnSize", -0.1)" & @CRLF & _
"val display = Flagship.getModification("displayBtn", true)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"val color = Flagship.getModification("btnColor", "(hello world !)", true)" & @CRLF & _
"val size = Flagship.getModification("btnSize", "red, green blue", true)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")