using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\.getModification\(\s*[""']([\w\-]+)['""]\s*,\s*([""'][^""]*['""]|[+-]?(?:\d*[.])?\d+|true|false|False|True)(?:\s*,\s*(?:true|false|\d+|""[^""]*""))?\s*\)";
string input = @"
val color = Flagship.getModification(""btnColor"", ""#0e5fe3"", true)
val size = Flagship.getModification(""btnSize"", 13, true)
val display = Flagship.getModification(""displayBtn"", true, true)
val color = Flagship.getModification(""btnColor"", ""#0e5fe3"")
val size = Flagship.getModification(""btnSize"", -0.1)
val display = Flagship.getModification(""displayBtn"", true)
val color = Flagship.getModification(""btnColor"", ""(hello world !)"", true)
val size = Flagship.getModification(""btnSize"", ""red, green blue"", true)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}