const regex = new RegExp('(?s)\\.getModification\\(\\s*["\\']([\\w\\-]+)[\\'"]\\s*,\\s*(["\\'][^"]*[\\'"]|[+-]?(?:\\d*[.])?\\d+|true|false|False|True)(?:\\s*,\\s*(?:true|false|\\d+|"[^"]*"))?\\s*\\)', 'gm')
const str = `
val color = Flagship.getModification("btnColor", "#0e5fe3", true)
val size = Flagship.getModification("btnSize", 13, true)
val display = Flagship.getModification("displayBtn", true, true)
val color = Flagship.getModification("btnColor", "#0e5fe3")
val size = Flagship.getModification("btnSize", -0.1)
val display = Flagship.getModification("displayBtn", true)
val color = Flagship.getModification("btnColor", "(hello world !)", true)
val size = Flagship.getModification("btnSize", "red, green blue", true)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}