import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\.getModification\\(\\s*[\"']([\\w\\-]+)['\"]\\s*,\\s*([\"'][^\"]*['\"]|[+-]?(?:\\d*[.])?\\d+|true|false|False|True)(?:\\s*,\\s*(?:true|false|\\d+|\"[^\"]*\"))?\\s*\\)";
final String string = "\n"
+ "val color = Flagship.getModification(\"btnColor\", \"#0e5fe3\", true)\n"
+ "val size = Flagship.getModification(\"btnSize\", 13, true)\n"
+ "val display = Flagship.getModification(\"displayBtn\", true, true)\n\n\n"
+ "val color = Flagship.getModification(\"btnColor\", \"#0e5fe3\")\n"
+ "val size = Flagship.getModification(\"btnSize\", -0.1)\n"
+ "val display = Flagship.getModification(\"displayBtn\", true)\n\n\n"
+ "val color = Flagship.getModification(\"btnColor\", \"(hello world !)\", true)\n"
+ "val size = Flagship.getModification(\"btnSize\", \"red, green blue\", true)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}