# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$"
test_str = ("\n"
"changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change\n"
"checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver\n"
"cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName\n"
"collapseList(pMultiList)\n"
"continueScript(pMsgStr)\n"
"convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert\n"
"convertISOtoDate(pDateStr) -- @Date @ISO @String\n"
"convertToDate(pDate) -- @Date @Convert @String\n"
"copyHTMLasRTFtoClipboard(pstrHTML)\n"
"createAliasIcon(pstrIconFile)\n"
"createHTMLLink for Params -- Params is a record\n"
"doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC\n"
"existsFinderItem(pPathStr)\n"
"expandPath(pPOSIXPath)\n"
"extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.