using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$";
string input = @"
changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change
checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver
cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName
collapseList(pMultiList)
continueScript(pMsgStr)
convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert
convertISOtoDate(pDateStr) -- @Date @ISO @String
convertToDate(pDate) -- @Date @Convert @String
copyHTMLasRTFtoClipboard(pstrHTML)
createAliasIcon(pstrIconFile)
createHTMLLink for Params -- Params is a record
doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC
existsFinderItem(pPathStr)
expandPath(pPOSIXPath)
extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}