const regex = /^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\(\\n]+)\\(([^\\)]*)\\)(?:\\s+--\\s+(.*))?$', 'gm')
const str = `
changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change
checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver
cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName
collapseList(pMultiList)
continueScript(pMsgStr)
convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert
convertISOtoDate(pDateStr) -- @Date @ISO @String
convertToDate(pDate) -- @Date @Convert @String
copyHTMLasRTFtoClipboard(pstrHTML)
createAliasIcon(pstrIconFile)
createHTMLLink for Params -- Params is a record
doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC
existsFinderItem(pPathStr)
expandPath(pPOSIXPath)
extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}