package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$`)
var str = `
changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change
checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver
cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName
collapseList(pMultiList)
continueScript(pMsgStr)
convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert
convertISOtoDate(pDateStr) -- @Date @ISO @String
convertToDate(pDate) -- @Date @Convert @String
copyHTMLasRTFtoClipboard(pstrHTML)
createAliasIcon(pstrIconFile)
createHTMLLink for Params -- Params is a record
doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC
existsFinderItem(pPathStr)
expandPath(pPOSIXPath)
extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}